Emails not sending with "Compose Email"
Incident Report for ClearSlide
Resolved
This incident has been resolved.
Posted Jun 09, 2017 - 10:22 PDT
Identified
We have identified the issue and are working on a fix
Posted Jun 09, 2017 - 09:33 PDT
Investigating
We are currently investigating reports of delays in sending emails through the Clearslide compose email service
Posted Jun 09, 2017 - 09:18 PDT