Issues with password reset emails
Incident Report for ClearSlide
Resolved
This incident is now resolved. Thank you for your patience.
Posted Sep 25, 2017 - 10:09 PDT
Identified
We have identified the issue with password reset emails and are working on a resolution.
Posted Sep 22, 2017 - 09:56 PDT
Investigating
We're experiencing issues with deliverability of password reset emails. We are currently investigating the issue and will provide updates soon.
Posted Sep 22, 2017 - 09:08 PDT