"Call Me" dial out feature is impacted
Incident Report for ClearSlide
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 10:54 PDT
Investigating
Some US and Canada-based users may experience intermittent issues with the "Call Me" dial-out feature. We are currently investigating the issue.
Posted Sep 27, 2021 - 15:15 PDT
This incident affected: Telephony.