Soft Phone non operational
Incident Report for ClearSlide
Resolved
This incident is resolved, thanks for your patience.
Posted Oct 20, 2017 - 14:47 PDT
Identified
We have identified an issue with our soft phone system and are working on a resolution.
Posted Oct 20, 2017 - 14:15 PDT